Archive for the 'IT' Category

My Lenovo Thinkpad Yoga failed to boot after firmware upgrade.

Jul 27 2014 Published by under IT

After i made a firmware update of my quite new Lenovo Thinkpad Yoga (20CD0001G) from version 1.14 to 1.17 the operating system did not boot at all. šŸ™

What has happend was that the firmware update software had obviously wiped the boot entry for the installed operating system from the EFI Boot Manager.

I discovered that after booting the Debian based Linux Live system Grml from an usb stick and checked the boot entries with efibootmgr.

The recovery of the missing boot entry can be achieved in several ways.

Afterwards i discovered that in can be done rely smart and simple withĀ efibootmgr:

 

But not for me. What i made in Grml while going beserk to fix this issue was mounting my whole stuff ( / at /mnt , /boot at /mnt/boot, the EFIĀ  System partition under /mnt/boot/efi)Ā  then doing a chroot to /mnt and installing GRUB. Don’t do this, the efibootmgr line above should made it. šŸ˜‰

 

Lesson learned. My machine is booting again and i got more confident with EFI. šŸ™‚

 

 

 

 

 

 

 

 

 

 

 

 

 

 

No responses yet

Lemon flavour

May 08 2013 Published by under Elmo,IT

P1000406_edited_800pxMy wife left for her academic job in the morning. Lemon flavour. I cleaned up the bathroom. Elmo gotsĀ  dressed up, than i cleared up the big mess in the kitchen. Now Elmo is taking his midmorning nap attached to me, while i am attached to the screen for some in-between-hacking as a short mental rest. Preparing some stuff for theĀ  volunteer IT-support i do in the afternoon for some local social work project. Before i make his lunch we have an appointment at the child doctor. Time to go now. Back home i will chop up some carrots. Simmer them together with Quinoa a.k.a Inca power seeds and blend it for Elmo with some olive oil. Than i feed him.Ā  Afterwards i am heading to my volunteer task, together with Elmo. Parental leave is such a quality time. Thank you.

Creative Commons Lizenzvertrag

No responses yet

Upgrade to Owncloud 5.0.0: webinterface looks garbled – how to fix

Apr 03 2013 Published by under IT

Detractors might argue: Upgrade paths for software that is provided in two editions like business/enterprise and community are often misleading for the free and open version. That seems to be part of the business model – or is the business model. šŸ˜‰

After I had upgraded to OwncloudĀ  5.0.0Ā  the webinterface looked weird andĀ  garbled. Looks like there is no CSS-Template at all is loaded?!Ā  If you dig deeper errorsĀ  are thrown by the webbrowser like: “remote_core.js not found”.

before_fix01

As it turned out there where some new configuration values missing in theĀ  databaseĀ  introducedĀ  with version 5.0.0.Ā These values should be created by the update/setup script run ( owncloud/lib/setup.php )- but the are not in my case.

So i created them with the following SQL-statements on the MySQL shell:

Restart, refresh, reload. Now Owncloud looks like it should. šŸ™‚

after_fix

PS: Should i file a bug report?

 

No responses yet